funcion logica en Excel SI.ERROR




Descripción la funcion logica en Excel SI.ERROR

La funcion logica en Excel SI.ERROR te permite manejar los errores que resulten de la evaluación de los argumentos de tu fórmula, es decir, si alguna operación realizada por los argumentos da como resultado un error, esta función lógica te permite identificarlos.

En caso de que no haya errores, la función devuelve el resultado de la fórmula.

Sintaxis de la funcion logica en Excel SI.ERROR

SI.ERROR(valor,valor_si_error)

  • valor: Es el argumento en el que se busca un error.
  • valor_si_error: Es el valor que se devuelve si la fórmula lo evalúa como error. Evalúa los siguientes tipos de error: #N/A, #¡VALOR!, #¡REF!, #¡DIV/0!, #¡NUM!, #¿NOMBRE?, #¡NULO!.

Ejemplo 1 de la funcion logica en Excel SI.ERROR

Tenemos la siguiente fórmula en Excel:

=SI.ERROR(B1/C1,”Error en la fórmula”)

Los valores numéricos de las celdas son:

  • Celda B1 igual a 1
  • Celda C1 igual a 0

Por lo tanto el resultado de la fórmula es “Error en la fórmula”. Excel lo procesa así:

  1. Realiza la división 1/0, el resultado de esta operación es un error, porque ningún número se puede dividir entre cero.
  2. Excel la asigna el resultado de error a la fórmula, y como en la función le indicamos que mensaje desplegar en caso de error, el resultado final es ” Error en la fórmula”.

Ejemplo 2 de la funcion logica en Excel SI.ERROR

En la siguiente tabla tenemos el promedio de las calificaciones que cada área obtuvo en la auditoría:

A
B
C
D
1
ÁREA
CALIF. AUD1
CALIF. AUD1
RESULTADO PROMEDIO
2 Finanzas 90 86
88
3 Sistemas 70 80
75
4 Mercadotecnia 85 91
88
5 RRHH 75 AA
Calificación no válida
6 Compras 83 YT
Calificación no válida

Cada calificación ingresada en la tabla debe contener números, porque si no es así, el promedio no puede aplicarse. En este caso no puedes sumar un número y una letra, ya que la puntuación va de 0 a 100, siendo 100 la calificación máxima que un área puede obtener y cero la calificación mínima.

De acuerdo a lo anterior para obtener el promedio de cada área y manejar los valores que hayan ingresado por error, utilizamos la funcion logica en Excel SI.ERROR:

=SI.ERROR((B2+C2)/2,”Calificación no válida”)

Aplicamos la fórmula a las siguientes áreas, y los resultados que obtenemos son los que puedes ver en la tabla.

funcion logica en Excel SI.ERROR

Así los valores ingresados en las celdas C5 y C6 no marcan un error de cálculo, sino que despliegan el mensaje de error “Calificación no válida”, ya que las calificaciones deben ser valores numéricos y no caracteres. De esta manera se usa la funcion logica en Excel SI.ERROR.

Si quieres saber sobre funciones lógicas en Excel da clic aquí.

Escríbenos si tienes alguna duda o comentario.

Leave a Reply